S'inscrire au signal RSS Se connecter pour voir ses MP Aller  l'index Aller au portail du forum Faire une recherche. FAQ S'inscrire au forum Connexion

:: Algorithmique et structure de données Niv 2--->ESCE Manno ::

 
Poster un nouveau sujet   Répondre au sujet    Portail Des Etudiants Index du Forum -> Espace des étudiants -> Cour, TD, TP & Mémoire -> TD / TP ESC
Sujet précédent :: Sujet suivant  
Auteur Message
Anonymous
Invité

Hors ligne




MessagePosté le: 18/12/2005 10:16:09    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

Correction de TD n° 2

Exercice n°1 :

Affichage 1 : 5, 3, 1, 1
Affichage 2 : 5, 3, 1, 2
Affichage 3 : 5, 3, 1, 3
Affichage finale : 13, 0

Exercice n°2 :

1°) Fonction Somme(x, y : entier) : entier
Début
Somme <--- x+y
Fin
2°) Fonction Calcul(x : entier) : entier
Début
Calcul <--- 4*x*x*x+2*x+9
Fin
3°) Procédure Convertir (x : entier ; VAR H, M, S : entier)
Début
H <--- x DIV 3600
M <--- (x MOD 3600) DIV 60
S <--- (x MOD 3600) MOD 60
Fin
4°) Procédure Permuter (VAR X, Y: entier)
VAR Temp : entier
Début
Temp <--- X
X <--Y
Y <----temp
Fin
5°) Fonction Premier (A, B : entier) : Booléen
Début
Tantque A<>B faire
Si A>B alors
A <----A- B
Sinon
A <--- B - A
Fin si
Fin Tantque
Si A= 1 alors
Premier <---Vrai
Sinon
Premier <----faux
Fin si
Fin

6°) Fonction Recherche (VAL : entier, T : TAB, N : entier) : entier
Var I : entier
Début
I <--- 1
Tantque (T [I] <> VAL) et (I <= N) faire
I <--- I+1
Fin Tantque
Si I<= N alors
Recherche_Seq <--- I
Sinon
Recherche_Seq <--- -1
Fin si
Fin
7°) Fonction Palindrome (S : chaîne de caractère, n : entier) : Booléen
VAR i : entier
Début
Pour i de 1 à n DIV 2 faire
Si (S[i] <> S [n-i+1]) alors
M <--- 1
Fin si
Fin Pour
Si M=0 alors
Palindrome <--- Vrai
Sinon
Palindrome <--- Faux
Fin si
Fin

Exercice n°3 :

1°) Procédure créer (N : entier ; VAR T : TAB)
VAR i : entier
Début
Pour i de 1 à N faire
Lire (T[i])
Fin Pour
Fin
2°) Procédure éclater (T : TAB, N : entier ; VAR T1, T2 : TAB, VAR j, k : entier)
VAR i : entier
Début
Pour i de 1 à N faire
Si T[i] > 0 alors
T1 [j] <-- T[i]
j <-- j + 1
Sinon
T2 [k] <--- T[i]
k <--- k+1
Fin si
Fin Pour
Fin
3°) Procédure Affichage (N : entier ; T : TAB)
VAR i : entier
Début
Pour i de 1 à n faire
Ecrire (T[i])
Fin Pour
Fin

Exercice n°4 :

1°) Procédure Remplir (N : entier ; VAR T1 : TAB)
VAR i : entier
Début
T1 [1] <--- 2
T1 [2] <--- 1
Pour i de 3 à N -1 faire
T1 [i] <--- T1 [i-2] - T1 [i-1]
Fin Pour
Fin
2°) Procédure Traitement (T1 : TAB ; VAR T2 : TAB ; N : entier)
VAR i, j : entier
Début
j <--- 1
Pour i de 1 à N faire
Si T1 [i] >= 0 alors
T2 [j] <--- T1 [i]
j <--- j + 1
Fin si
Fin pour
Tantque i <>0 faire
Si T1 [i] < 0 alors
T2 [j] <--- T1 [i]
j <--- j + 1
Fin si
i <--- i - 1
Fin Tantque
Fin
3°) Procédure Affichage (N : entier ; T1 : TAB)
VAR i : entier
Début
Pour i de 1 à N faire
Ecrire (T1 [i])
Fin Pour
Fin

Exercice n°5 :

1°) Procédure Remplissage (N : entier ; VAR V : TAB)
VAR i : entier
Début
Pour i de 1 à N faire
Lire (V[i])
Fin Pour
Fin
2°) Procédure Lecture (VAR j, k : entier)
Début
Répéter
Lire (j, k)
Jusqu’à (j>0 et k > j et k < N)
Fin
3°) Procédure Traitement (N, j, k : entier ; VAR V : TAB)
VAR i, Temp : entier
Début
Pour i de j à (j+k) DIV 2 faire
Temp <--- V [i]
V [i] <--- V [k+j-i]
V [k+j-i] <--- Temp
Fin pour
Fin

Exercice n°6 :

1°) Procédure Mesure (VAR Longueur : entier ; VAR Erreur : Booléen)
VAR i, Temp : entier
Début
Erreur <--- Vrai
Répéter
Lire (Longueur)
Jusqu’à Longueur > 0
Si Longueur > 30 ou Longueur < 125 alors
Erreur <--- Faux
Fin si
Fin
2°) Procédure Monte (VAR Elévation : réel ; Longueur : entier)
Début
Elévation <--- 130 - Longueur
Fin
3°) Procédure Calcule (VAR Durée : réel ; Longueur : entier)
Début
Durée <--- Longueur*25/3
Fin

4°) Procédure Affiche (Elévation : réel)
Début
Ecrire (" L’Elévation est : ", Elévation)
Fin
5°) Procédure Attend (Durée : réel)
Début
X  Heure_ Système () + Durée
Tantque Heure_ Système () <> X faire
Ecrire (" Attendez un peu :")
Fin Tantque
Fin
6°) Algorithme Robot_ Assemblage
VAR Longueur, Elévation, Durée : réel
Erreur : Booléen
Début
Mesure (Longueur, Erreur)
Si Non (Erreur) alors
Monte (Elévation, Longueur)
Affiche (Elévation)
Calcule (Durée, Longueur)
Attend (Durée : réel)
Fin si
Fin

Exercice n°7 :

1°) Procédure Choix (Option : caractère)
Début
Selon Option Faire
R : Réserver (Capa, Vol)
C : Consulter (Capa, Vol, PLibres)
A : Annuler (Vol)
F : Ecrire (Msg6)
Fin selon
Fin
2°) Procédure Réserver (Capa : entier ; VAR Vol : Vecteur)
Début
Pour Place de 1 à Capa faire
Si Vol (Place) = 0 alors
Vol (Place) <--- 1
Ecrire (Msg1, Place)
Fin si
Fin pour
Fin
3°) Procédure Annuler (VAR Vol : Vecteur)
Début
Lire (Place)
Vol (Place) <--- 0
Ecrire (Msg2, Place)
Fin

4°) Procédure Consulter (Capa : entier ; Vol : Vecteur, VAR PLibres : entier)
Début
PLibres <--- 0
Pour Place de 1 à Capa faire
Si Vol (Place) = 0 alors
Ecrire (Msg4, Place, Msg3)
PLibres <--- PLibres + 1
Fin si
Fin pour
Ecrire (Msg5, PLibres)
Fin


Proposé par : Mr BEN MAHMOUD Chaker


Revenir en haut
Publicité






MessagePosté le: 18/12/2005 10:16:09    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
radsi
Invité

Hors ligne




MessagePosté le: 20/12/2005 15:42:26    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

merci monsieur TOP

Revenir en haut
inconnu
Modérateurs
Modérateurs

Hors ligne

Inscrit le: 30 Oct 2005
Messages: 2 434
Vous êtes: Etudiant(e)
Section: CIN
Point(s): 1 078
Moyenne de points: 0,44
Homme Poisson (20 Fev - 20 Mars) Buffle

MessagePosté le: 25/12/2005 13:06:34    Sujet du message: salut radsi Répondre en citant

c'est les administrateurs qu'ils les a chercher et poster pas Mr (mais c'est Mr qu'il les a fait).
J'espère que t'en a besoin radsi.
====================
http://ws-esc.xooit.com


Revenir en haut
Visiter le site web du posteur
kordial
Invité

Hors ligne




MessagePosté le: 28/04/2006 03:42:59    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

Même Einstein ne signe pas ses documents par Monsieur Einstein.. Quelle modestie!
Et puis l'abbréviation de Monsieur en français c'est M. non pas Mr la deuxième c'est de l'anglais (Mister)..
Alors t'as gobé les deux leçons Monsieur je ne sais qui, ou est ce que t'as besoin d'un 9ma3?


Revenir en haut
Tommy Mad
1er année Sup
1er année Sup

Hors ligne

Inscrit le: 26 Mar 2006
Messages: 1 434
Vous êtes: Etudiant(e)
Localisation: ESC Manouba
Point(s): 116
Moyenne de points: 0,08

MessagePosté le: 28/04/2006 14:08:43    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

mé gentillesse é kel élégance de parole
avant tous c pas Mr "M." Ben Mahmoud qui a édité ça pour lui reprocher le fait d'écrir son nom mais un modeste étudiant qui a signalé que c proposer par ce prof.
é icy onn ècri ts ckon ve com onn le daisyr
====================
Tommy Mad un homme saint d'une rareté incontestable


Revenir en haut
Visiter le site web du posteur
maher_tatu
Modérateurs
Modérateurs

Hors ligne

Inscrit le: 01 Nov 2005
Messages: 3 082
Vous êtes: Etudiant(e)
Université: ESC
Section: IAG
Niveau: 3
Point(s): 2 749
Moyenne de points: 0,89
Homme Lion (24 Juil - 23 Août) Rat

MessagePosté le: 28/04/2006 18:03:07    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

bel hak ,chbik mnarvez barcha kordial.ehmed rabi elli fema corection é il fo metr le nom 2celui ki la réalisé ca é on ecri com on veu.warani chta3mel w posti haja tesslah

Revenir en haut
Tommy Mad
1er année Sup
1er année Sup

Hors ligne

Inscrit le: 26 Mar 2006
Messages: 1 434
Vous êtes: Etudiant(e)
Localisation: ESC Manouba
Point(s): 116
Moyenne de points: 0,08

MessagePosté le: 28/04/2006 18:46:00    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno Répondre en citant

é san fote bien sour kar tou le mond va te corriger
====================
Tommy Mad un homme saint d'une rareté incontestable


Revenir en haut
Visiter le site web du posteur
Contenu Sponsorisé






MessagePosté le: 05/12/2016 19:39:00    Sujet du message: Algorithmique et structure de données Niv 2--->ESCE Manno

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Portail Des Etudiants Index du Forum -> Espace des étudiants -> Cour, TD, TP & Mémoire -> TD / TP ESC Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Portail | Index | Panneau d’administration | Créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Flowers of Evil © original theme by larme d'ange 2006 | complètement modifié par Carbanion pour le Forum WS-ESC - 2008-09©
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com